aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/common/183 partial dependency/declare_dependency/meson.build
diff options
context:
space:
mode:
authorAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2023-10-10 14:33:42 +0000
committerAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2023-10-10 14:33:42 +0000
commitaf1a266670d040d2f4083ff309d732d648afba2a (patch)
tree2fc46203448ddcc6f81546d379abfaeb323575e9 /meson/test cases/common/183 partial dependency/declare_dependency/meson.build
parente02cda008591317b1625707ff8e115a4841aa889 (diff)
Add submodule dependency filesHEADmaster
Change-Id: Iaf8d18082d3991dec7c0ebbea540f092188eb4ec
Diffstat (limited to 'meson/test cases/common/183 partial dependency/declare_dependency/meson.build')
-rw-r--r--meson/test cases/common/183 partial dependency/declare_dependency/meson.build32
1 files changed, 32 insertions, 0 deletions
diff --git a/meson/test cases/common/183 partial dependency/declare_dependency/meson.build b/meson/test cases/common/183 partial dependency/declare_dependency/meson.build
new file mode 100644
index 000000000..3783f6694
--- /dev/null
+++ b/meson/test cases/common/183 partial dependency/declare_dependency/meson.build
@@ -0,0 +1,32 @@
+# Copyright © 2018 Intel Corporation
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+dec_sub_dep = declare_dependency(
+ include_directories : include_directories('headers'),
+)
+
+dec_dep = declare_dependency(
+ sources : files('headers/foo.c'),
+ dependencies : dec_sub_dep,
+)
+
+sub_dep = dec_dep.partial_dependency(includes : true)
+
+dec_exe = executable(
+ 'declare_dep',
+ files('main.c', 'other.c'),
+ dependencies : sub_dep,
+)
+
+test('Declare Dependency', dec_exe)