aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/common/217 test priorities/meson.build
diff options
context:
space:
mode:
authorAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2023-10-10 14:33:42 +0000
committerAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2023-10-10 14:33:42 +0000
commitaf1a266670d040d2f4083ff309d732d648afba2a (patch)
tree2fc46203448ddcc6f81546d379abfaeb323575e9 /meson/test cases/common/217 test priorities/meson.build
parente02cda008591317b1625707ff8e115a4841aa889 (diff)
Add submodule dependency filesHEADmaster
Change-Id: Iaf8d18082d3991dec7c0ebbea540f092188eb4ec
Diffstat (limited to 'meson/test cases/common/217 test priorities/meson.build')
-rw-r--r--meson/test cases/common/217 test priorities/meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/meson/test cases/common/217 test priorities/meson.build b/meson/test cases/common/217 test priorities/meson.build
new file mode 100644
index 000000000..33c6fa382
--- /dev/null
+++ b/meson/test cases/common/217 test priorities/meson.build
@@ -0,0 +1,22 @@
+project('test priorities', 'c')
+
+test_prog = find_program('testprog.py')
+
+test('priority 0', test_prog,
+ args : ['0'],
+)
+
+test('priority neg 10', test_prog,
+ args : ['-10'],
+ priority : -10
+)
+
+test('priority 1000', test_prog,
+ args : ['1000'],
+ priority : 1000
+)
+
+test('priority 50', test_prog,
+ args : ['50'],
+ priority : 50
+)