aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/common/62 string arithmetic/meson.build
diff options
context:
space:
mode:
authorAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2023-10-10 14:33:42 +0000
committerAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2023-10-10 14:33:42 +0000
commitaf1a266670d040d2f4083ff309d732d648afba2a (patch)
tree2fc46203448ddcc6f81546d379abfaeb323575e9 /meson/test cases/common/62 string arithmetic/meson.build
parente02cda008591317b1625707ff8e115a4841aa889 (diff)
Add submodule dependency filesHEADmaster
Change-Id: Iaf8d18082d3991dec7c0ebbea540f092188eb4ec
Diffstat (limited to 'meson/test cases/common/62 string arithmetic/meson.build')
-rw-r--r--meson/test cases/common/62 string arithmetic/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/meson/test cases/common/62 string arithmetic/meson.build b/meson/test cases/common/62 string arithmetic/meson.build
new file mode 100644
index 000000000..59567de49
--- /dev/null
+++ b/meson/test cases/common/62 string arithmetic/meson.build
@@ -0,0 +1,16 @@
+project('string arithmetic', 'c')
+
+if 'foo' + 'bar' != 'foobar'
+ error('String concatenation is broken')
+endif
+
+if 'foo' + 'bar' + 'baz' != 'foobarbaz'
+ error('Many-string concatenation is broken')
+endif
+
+a = 'a'
+b = 'b'
+
+if a + b + 'c' != 'abc'
+ error('String concat with variables is broken.')
+endif