aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/frameworks/23 hotdoc/meson.build
diff options
context:
space:
mode:
authorAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2023-10-10 14:33:42 +0000
committerAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2023-10-10 14:33:42 +0000
commitaf1a266670d040d2f4083ff309d732d648afba2a (patch)
tree2fc46203448ddcc6f81546d379abfaeb323575e9 /meson/test cases/frameworks/23 hotdoc/meson.build
parente02cda008591317b1625707ff8e115a4841aa889 (diff)
Add submodule dependency filesHEADmaster
Change-Id: Iaf8d18082d3991dec7c0ebbea540f092188eb4ec
Diffstat (limited to 'meson/test cases/frameworks/23 hotdoc/meson.build')
-rw-r--r--meson/test cases/frameworks/23 hotdoc/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/meson/test cases/frameworks/23 hotdoc/meson.build b/meson/test cases/frameworks/23 hotdoc/meson.build
new file mode 100644
index 000000000..dd3c92acd
--- /dev/null
+++ b/meson/test cases/frameworks/23 hotdoc/meson.build
@@ -0,0 +1,15 @@
+project('hotdoc', 'c')
+
+hotdoc = find_program('hotdoc', required: false)
+if not hotdoc.found()
+ error('MESON_SKIP_TEST hotdoc not found.')
+endif
+
+subdir('doc')
+
+assert(hotdoc.has_extensions(['gi-extension']) == true,
+ 'GI extension should always be found.')
+
+assert(hotdoc.has_extensions(['gi-extension', 'no-way-you-exist-extension']) == false,
+ 'A hotdoc extension called "no-way-you-exist-extension" should never be found.')
+