aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/unit/10 build_rpath/meson.build
diff options
context:
space:
mode:
authorAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2023-10-10 14:33:42 +0000
committerAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2023-10-10 14:33:42 +0000
commitaf1a266670d040d2f4083ff309d732d648afba2a (patch)
tree2fc46203448ddcc6f81546d379abfaeb323575e9 /meson/test cases/unit/10 build_rpath/meson.build
parente02cda008591317b1625707ff8e115a4841aa889 (diff)
Add submodule dependency filesHEADmaster
Change-Id: Iaf8d18082d3991dec7c0ebbea540f092188eb4ec
Diffstat (limited to 'meson/test cases/unit/10 build_rpath/meson.build')
-rw-r--r--meson/test cases/unit/10 build_rpath/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/meson/test cases/unit/10 build_rpath/meson.build b/meson/test cases/unit/10 build_rpath/meson.build
new file mode 100644
index 000000000..c0bc3bd27
--- /dev/null
+++ b/meson/test cases/unit/10 build_rpath/meson.build
@@ -0,0 +1,16 @@
+project('build rpath', 'c', 'cpp')
+
+subdir('sub')
+executable('prog', 'prog.c',
+ link_with : l,
+ build_rpath : '/foo/bar',
+ install_rpath : '/baz',
+ install : true,
+ )
+
+executable('progcxx', 'prog.cc',
+ link_with : l,
+ build_rpath : '/foo/bar',
+ install_rpath : 'baz',
+ install : true,
+ )