aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/unit/91 devenv/meson.build
diff options
context:
space:
mode:
authorAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2023-10-10 14:33:42 +0000
committerAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2023-10-10 14:33:42 +0000
commitaf1a266670d040d2f4083ff309d732d648afba2a (patch)
tree2fc46203448ddcc6f81546d379abfaeb323575e9 /meson/test cases/unit/91 devenv/meson.build
parente02cda008591317b1625707ff8e115a4841aa889 (diff)
Add submodule dependency filesHEADmaster
Change-Id: Iaf8d18082d3991dec7c0ebbea540f092188eb4ec
Diffstat (limited to 'meson/test cases/unit/91 devenv/meson.build')
-rw-r--r--meson/test cases/unit/91 devenv/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson/test cases/unit/91 devenv/meson.build b/meson/test cases/unit/91 devenv/meson.build
new file mode 100644
index 000000000..40b9c861d
--- /dev/null
+++ b/meson/test cases/unit/91 devenv/meson.build
@@ -0,0 +1,12 @@
+project('devenv', 'c')
+
+meson.add_devenv('TEST_A=1')
+foo_dep = dependency('foo', fallback: 'sub')
+
+env = environment()
+env.append('TEST_B', ['2', '3'], separator: '+')
+meson.add_devenv(env)
+
+# This exe links on a library built in another directory. On Windows this means
+# PATH must contain builddir/subprojects/sub to be able to run it.
+executable('app', 'main.c', dependencies: foo_dep, install: true)