aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/meson.build
diff options
context:
space:
mode:
authorTimos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>2023-10-10 11:40:56 +0000
committerTimos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>2023-10-10 11:40:56 +0000
commite02cda008591317b1625707ff8e115a4841aa889 (patch)
treeaee302e3cf8b59ec2d32ec481be3d1afddfc8968 /plugins/meson.build
parentcc668e6b7e0ffd8c9d130513d12053cf5eda1d3b (diff)
Introduce Virtio-loopback epsilon release:
Epsilon release introduces a new compatibility layer which make virtio-loopback design to work with QEMU and rust-vmm vhost-user backend without require any changes. Signed-off-by: Timos Ampelikiotis <t.ampelikiotis@virtualopensystems.com> Change-Id: I52e57563e08a7d0bdc002f8e928ee61ba0c53dd9
Diffstat (limited to 'plugins/meson.build')
-rw-r--r--plugins/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/plugins/meson.build b/plugins/meson.build
new file mode 100644
index 000000000..b3de57853
--- /dev/null
+++ b/plugins/meson.build
@@ -0,0 +1,15 @@
+plugin_ldflags = []
+# Modules need more symbols than just those in plugins/qemu-plugins.symbols
+if not enable_modules
+ if 'CONFIG_HAS_LD_DYNAMIC_LIST' in config_host
+ plugin_ldflags = ['-Wl,--dynamic-list=qemu-plugins-ld.symbols']
+ elif 'CONFIG_HAS_LD_EXPORTED_SYMBOLS_LIST' in config_host
+ plugin_ldflags = ['-Wl,-exported_symbols_list,qemu-plugins-ld64.symbols']
+ endif
+endif
+
+specific_ss.add(when: 'CONFIG_PLUGIN', if_true: [files(
+ 'loader.c',
+ 'core.c',
+ 'api.c',
+), declare_dependency(link_args: plugin_ldflags)])