aboutsummaryrefslogtreecommitdiffstats
path: root/bsd-user/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'bsd-user/meson.build')
-rw-r--r--bsd-user/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/bsd-user/meson.build b/bsd-user/meson.build
new file mode 100644
index 000000000..87885d91e
--- /dev/null
+++ b/bsd-user/meson.build
@@ -0,0 +1,17 @@
+if not have_bsd_user
+ subdir_done()
+endif
+
+bsd_user_ss.add(files(
+ 'bsdload.c',
+ 'elfload.c',
+ 'main.c',
+ 'mmap.c',
+ 'signal.c',
+ 'strace.c',
+ 'syscall.c',
+ 'uaccess.c',
+))
+
+# Pull in the OS-specific build glue, if any
+subdir(targetos)