aboutsummaryrefslogtreecommitdiffstats
path: root/capstone/packages/freebsd/ports
diff options
context:
space:
mode:
Diffstat (limited to 'capstone/packages/freebsd/ports')
-rw-r--r--capstone/packages/freebsd/ports/devel/capstone/Makefile23
-rw-r--r--capstone/packages/freebsd/ports/devel/capstone/pkg-descr17
-rw-r--r--capstone/packages/freebsd/ports/devel/capstone/pkg-plist14
3 files changed, 54 insertions, 0 deletions
diff --git a/capstone/packages/freebsd/ports/devel/capstone/Makefile b/capstone/packages/freebsd/ports/devel/capstone/Makefile
new file mode 100644
index 000000000..8d457d9c2
--- /dev/null
+++ b/capstone/packages/freebsd/ports/devel/capstone/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= capstone
+PORTVERSION= 4.0.0
+CATEGORIES= devel
+MASTER_SITES= http://capstone-engine.org/download/${PORTVERSION}/
+
+MAINTAINER= oliver.pntr@gmail.com
+COMMENT= Multi-platform, multi-architecture disassembly framework
+
+LICENSE= BSD3CLAUSE
+
+USES= gmake
+USE_LDCONFIG= yes
+
+MAKE_ENV+= INSTALL_LIB="${INSTALL_LIB}" \
+ INSTALL_DATA="${INSTALL_DATA}"
+
+post-build:
+ # The pkgconfig file is generated and points to stagedir
+ ${REINPLACE_CMD} -e '/libdir/s|\(libdir=\)\(.*\)\(devel/capstone/work/stage\)|\1|g' ${WRKSRC}/capstone.pc
+
+.include <bsd.port.mk>
diff --git a/capstone/packages/freebsd/ports/devel/capstone/pkg-descr b/capstone/packages/freebsd/ports/devel/capstone/pkg-descr
new file mode 100644
index 000000000..3a88591d8
--- /dev/null
+++ b/capstone/packages/freebsd/ports/devel/capstone/pkg-descr
@@ -0,0 +1,17 @@
+Capstone is a lightweight multi-platform, multi-architecture disassembly
+framework.
+
+Features:
+ * Supported architectures: ARM, ARM64 (aka ARMv8), Mips, PowerPC, Sparc,
+ SystemZ, X86, X86_64 & XCore.
+ * Clean/simple/lightweight/intuitive architecture-neutral API
+ * Provide details on disassembled instruction (called "decomposer")
+ * Provide some semantics of the disassembled instruction, such as list of
+ implicit registers read & written.
+ * Implemented in pure C language, with bindings for Python, Ruby, C#, Java,
+ Javascript, GO, OCaml & Vala available.
+ * Native support for Windows & *nix (including MacOSX, Linux, *BSD & Solaris)
+ * Thread-safe by design
+ * Distributed under the open source BSD license
+
+WWW: http://capstone-engine.org/
diff --git a/capstone/packages/freebsd/ports/devel/capstone/pkg-plist b/capstone/packages/freebsd/ports/devel/capstone/pkg-plist
new file mode 100644
index 000000000..b4aab3c43
--- /dev/null
+++ b/capstone/packages/freebsd/ports/devel/capstone/pkg-plist
@@ -0,0 +1,14 @@
+include/capstone/arm.h
+include/capstone/arm64.h
+include/capstone/capstone.h
+include/capstone/mips.h
+include/capstone/ppc.h
+include/capstone/sparc.h
+include/capstone/systemz.h
+include/capstone/x86.h
+include/capstone/xcore.h
+include/capstone/platform.h
+lib/libcapstone.a
+lib/libcapstone.so
+libdata/pkgconfig/capstone.pc
+@dirrmtry include/capstone