aboutsummaryrefslogtreecommitdiffstats
path: root/hw/m68k/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hw/m68k/meson.build')
-rw-r--r--hw/m68k/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/hw/m68k/meson.build b/hw/m68k/meson.build
new file mode 100644
index 000000000..31248641d
--- /dev/null
+++ b/hw/m68k/meson.build
@@ -0,0 +1,8 @@
+m68k_ss = ss.source_set()
+m68k_ss.add(when: 'CONFIG_AN5206', if_true: files('an5206.c', 'mcf5206.c'))
+m68k_ss.add(when: 'CONFIG_MCF5208', if_true: files('mcf5208.c', 'mcf_intc.c'))
+m68k_ss.add(when: 'CONFIG_NEXTCUBE', if_true: files('next-kbd.c', 'next-cube.c'))
+m68k_ss.add(when: 'CONFIG_Q800', if_true: files('q800.c'))
+m68k_ss.add(when: 'CONFIG_M68K_VIRT', if_true: files('virt.c'))
+
+hw_arch += {'m68k': m68k_ss}