aboutsummaryrefslogtreecommitdiffstats
path: root/hw/mem/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hw/mem/meson.build')
-rw-r--r--hw/mem/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/hw/mem/meson.build b/hw/mem/meson.build
new file mode 100644
index 000000000..82f86d117
--- /dev/null
+++ b/hw/mem/meson.build
@@ -0,0 +1,9 @@
+mem_ss = ss.source_set()
+mem_ss.add(files('memory-device.c'))
+mem_ss.add(when: 'CONFIG_DIMM', if_true: files('pc-dimm.c'))
+mem_ss.add(when: 'CONFIG_NPCM7XX', if_true: files('npcm7xx_mc.c'))
+mem_ss.add(when: 'CONFIG_NVDIMM', if_true: files('nvdimm.c'))
+
+softmmu_ss.add_all(when: 'CONFIG_MEM_DEVICE', if_true: mem_ss)
+
+softmmu_ss.add(when: 'CONFIG_SPARSE_MEM', if_true: files('sparse-mem.c'))