aboutsummaryrefslogtreecommitdiffstats
path: root/hw/sh4/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hw/sh4/meson.build')
-rw-r--r--hw/sh4/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/hw/sh4/meson.build b/hw/sh4/meson.build
new file mode 100644
index 000000000..424d5674d
--- /dev/null
+++ b/hw/sh4/meson.build
@@ -0,0 +1,9 @@
+sh4_ss = ss.source_set()
+sh4_ss.add(files(
+ 'sh7750.c',
+ 'sh7750_regnames.c',
+))
+sh4_ss.add(when: 'CONFIG_R2D', if_true: files('r2d.c'))
+sh4_ss.add(when: 'CONFIG_SHIX', if_true: files('shix.c'))
+
+hw_arch += {'sh4': sh4_ss}