aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/cmake/20 cmake file/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/cmake/20 cmake file/meson.build')
-rw-r--r--meson/test cases/cmake/20 cmake file/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/meson/test cases/cmake/20 cmake file/meson.build b/meson/test cases/cmake/20 cmake file/meson.build
new file mode 100644
index 000000000..758bbee2d
--- /dev/null
+++ b/meson/test cases/cmake/20 cmake file/meson.build
@@ -0,0 +1,14 @@
+project(
+ 'cmake config file',
+)
+
+cmake = import('cmake')
+
+cmake_conf = configuration_data()
+cmake_conf.set_quoted('foo', 'bar')
+cmake.configure_package_config_file(
+ name : 'foolib',
+ input : 'foolib.cmake.in',
+ install_dir : get_option('libdir') / 'cmake',
+ configuration : cmake_conf,
+)