aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/common/120 extract all shared library/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/common/120 extract all shared library/meson.build')
-rw-r--r--meson/test cases/common/120 extract all shared library/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/meson/test cases/common/120 extract all shared library/meson.build b/meson/test cases/common/120 extract all shared library/meson.build
new file mode 100644
index 000000000..340c031b7
--- /dev/null
+++ b/meson/test cases/common/120 extract all shared library/meson.build
@@ -0,0 +1,14 @@
+project('extract all', 'c', 'cpp')
+
+if meson.backend() == 'xcode'
+ error('MESON_SKIP_TEST: Xcode backend does not handle libraries with only objects, not sources.')
+endif
+
+a = static_library('a', 'one.c', 'two.c')
+b = static_library('b', 'three.c', 'four.c')
+c = shared_library('c',
+ objects : [a.extract_all_objects(), b.extract_all_objects()],
+ vs_module_defs : 'func1234.def')
+
+e = executable('proggie', 'prog.c', link_with : c)
+test('extall', e)