aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/common/145 recursive linking/edge-cases/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/common/145 recursive linking/edge-cases/meson.build')
-rw-r--r--meson/test cases/common/145 recursive linking/edge-cases/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson/test cases/common/145 recursive linking/edge-cases/meson.build b/meson/test cases/common/145 recursive linking/edge-cases/meson.build
new file mode 100644
index 000000000..6a46266b4
--- /dev/null
+++ b/meson/test cases/common/145 recursive linking/edge-cases/meson.build
@@ -0,0 +1,9 @@
+# Test https://github.com/mesonbuild/meson/issues/2096
+# Note that removing 'shnodep' from link_with: makes the error go away because
+# then it is added after the static library is added to the link command.
+test('shared-static', executable('shstexe', 'shstmain.c', link_with : [shnodep, stshdep]))
+
+# Static library that needs a symbol defined in an object file. This already
+# works, but good to add a test case early.
+stodep = static_library('stodep', 'libsto.c')
+test('stodep', executable('stodep', 'stomain.c', 'stobuilt.c', link_with : stodep))