aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/common/160 custom target template substitution/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/common/160 custom target template substitution/meson.build')
-rw-r--r--meson/test cases/common/160 custom target template substitution/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/meson/test cases/common/160 custom target template substitution/meson.build b/meson/test cases/common/160 custom target template substitution/meson.build
new file mode 100644
index 000000000..737408ebf
--- /dev/null
+++ b/meson/test cases/common/160 custom target template substitution/meson.build
@@ -0,0 +1,17 @@
+project('custom target template substitution', 'c')
+
+check = find_program('checkcopy.py')
+
+config = configuration_data()
+
+config_file = configure_file(configuration : config, output : 'x@IN')
+
+# Check that substitution does not find @FOO@ and then misses @INPUT0@.
+# Check the resulting x@INPUT1@ is not replaced.
+foo = custom_target('runcheck',
+ input : [config_file, 'foo.c.in'],
+ output : 'foo.c',
+ command : [check, '-D@FOO@INPUT0@PUT1@', '@INPUT1@', '@OUTPUT@']
+)
+
+executable('foo', foo)