aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/common/171 initial c_args/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/common/171 initial c_args/meson.build')
-rw-r--r--meson/test cases/common/171 initial c_args/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson/test cases/common/171 initial c_args/meson.build b/meson/test cases/common/171 initial c_args/meson.build
new file mode 100644
index 000000000..638f8c277
--- /dev/null
+++ b/meson/test cases/common/171 initial c_args/meson.build
@@ -0,0 +1,7 @@
+project('options', 'c')
+
+# Test passing c_args and c_link_args options from the command line.
+assert(get_option('c_args') == ['-funroll-loops'],
+ 'Incorrect value for c_args option.')
+assert(get_option('c_link_args') == ['-Dtest_harmless_but_useless_link_arg'],
+ 'Incorrect value for c_link_args option.')