aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/common/181 same target name flat layout/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/common/181 same target name flat layout/meson.build')
-rw-r--r--meson/test cases/common/181 same target name flat layout/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/meson/test cases/common/181 same target name flat layout/meson.build b/meson/test cases/common/181 same target name flat layout/meson.build
new file mode 100644
index 000000000..cfad2c2a5
--- /dev/null
+++ b/meson/test cases/common/181 same target name flat layout/meson.build
@@ -0,0 +1,15 @@
+project('subdir targets', 'c')
+
+if meson.backend() == 'xcode'
+ error('MESON_SKIP_TEST: many targets with the same name not supported in Xcode. Patches welcome.')
+endif
+
+# Idea behind this test is to create targets with identical name
+# but different output files. We can do this by choosing different
+# name_prefix of libraries. Target id does not depend on name_prefix.
+
+main_foo = static_library('foo', 'foo.c', name_prefix : 'main')
+subdir('subdir') # defines subdir_foo
+
+exe = executable('prog', 'main.c', link_with : [main_foo, subdir_foo])
+test('main test', exe)