aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/common/202 custom target build by default/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/common/202 custom target build by default/meson.build')
-rw-r--r--meson/test cases/common/202 custom target build by default/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson/test cases/common/202 custom target build by default/meson.build b/meson/test cases/common/202 custom target build by default/meson.build
new file mode 100644
index 000000000..7c81aa254
--- /dev/null
+++ b/meson/test cases/common/202 custom target build by default/meson.build
@@ -0,0 +1,10 @@
+project('custom-target-dir-install', 'c')
+
+docgen = find_program('docgen.py')
+
+custom_target('docgen',
+ output : 'html',
+ command : [docgen, '@OUTPUT@'],
+ install : true,
+ build_by_default : false,
+ install_dir : join_paths(get_option('datadir'), 'doc/testpkgname'))