aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/common/230 external project/libfoo/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/common/230 external project/libfoo/meson.build')
-rw-r--r--meson/test cases/common/230 external project/libfoo/meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/meson/test cases/common/230 external project/libfoo/meson.build b/meson/test cases/common/230 external project/libfoo/meson.build
new file mode 100644
index 000000000..941e13f94
--- /dev/null
+++ b/meson/test cases/common/230 external project/libfoo/meson.build
@@ -0,0 +1,22 @@
+mod = import('unstable_external_project')
+
+target_system = target_machine.system()
+if target_system in ['windows', 'cygwin']
+ libext = 'dll'
+elif target_system == 'darwin'
+ libext = 'dylib'
+else
+ libext = 'so'
+endif
+
+p = mod.add_project('configure',
+ configure_options : [
+ '--prefix=@PREFIX@',
+ '--libdir=@PREFIX@/@LIBDIR@',
+ '--includedir=@PREFIX@/@INCLUDEDIR@',
+ '--libext=' + libext,
+ ],
+)
+
+libfoo_dep = declare_dependency(link_with : somelib,
+ dependencies : p.dependency('foo'))