aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/common/27 multiline string/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/common/27 multiline string/meson.build')
-rw-r--r--meson/test cases/common/27 multiline string/meson.build37
1 files changed, 37 insertions, 0 deletions
diff --git a/meson/test cases/common/27 multiline string/meson.build b/meson/test cases/common/27 multiline string/meson.build
new file mode 100644
index 000000000..a87d29ad9
--- /dev/null
+++ b/meson/test cases/common/27 multiline string/meson.build
@@ -0,0 +1,37 @@
+project('multiline string', 'c')
+
+x = '''hello again'''
+y = '''hello
+again'''
+
+if x == y
+ error('Things are wrong.')
+endif
+
+multieol = '''
+'''
+singleeol = '\n'
+
+if multieol != singleeol
+ error('Newline quoting is broken.')
+endif
+
+# And one more for good measure.
+quote1 = ''' ' '''.strip()
+quote2 = '\''
+
+if quote1 != quote2
+ error('Single quote quoting is broken.')
+endif
+
+cc = meson.get_compiler('c')
+prog = '''
+#include <stdio.h>
+
+int main(void) {
+ int num = 1;
+ printf("%d\n", num);
+ return 0;
+}'''
+
+assert(cc.compiles(prog), 'multline test compile failed')