aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/common/55 exe static shared/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/common/55 exe static shared/meson.build')
-rw-r--r--meson/test cases/common/55 exe static shared/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/meson/test cases/common/55 exe static shared/meson.build b/meson/test cases/common/55 exe static shared/meson.build
new file mode 100644
index 000000000..69ede5e87
--- /dev/null
+++ b/meson/test cases/common/55 exe static shared/meson.build
@@ -0,0 +1,15 @@
+project('statchain', 'c')
+
+subdir('subdir')
+# Test that -fPIC in c_args is also accepted (on platforms where it's permitted)
+picflag = []
+if not ['darwin', 'windows'].contains(host_machine.system())
+ picflag = ['-fPIC']
+endif
+statlib2 = static_library('stat2', 'stat2.c', c_args : picflag, pic : false)
+# Test that pic is needed for both direct and indirect static library
+# dependencies of shared libraries (on Linux and BSD)
+statlib = static_library('stat', 'stat.c', link_with : [shlib, statlib2], pic : true)
+shlib2 = shared_library('shr2', 'shlib2.c', link_with : statlib)
+exe = executable('prog', 'prog.c', link_with : shlib2)
+test('runtest', exe)