aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/common/73 shared subproject 2/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/common/73 shared subproject 2/meson.build')
-rw-r--r--meson/test cases/common/73 shared subproject 2/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson/test cases/common/73 shared subproject 2/meson.build b/meson/test cases/common/73 shared subproject 2/meson.build
new file mode 100644
index 000000000..064732597
--- /dev/null
+++ b/meson/test cases/common/73 shared subproject 2/meson.build
@@ -0,0 +1,13 @@
+project('A', 'c')
+
+# Same as the previous test but use C and B in
+# the opposite order.
+
+C = subproject('C')
+c = C.get_variable('c')
+
+B = subproject('B')
+b = B.get_variable('b')
+
+a = executable('a', 'a.c', link_with : [b, c])
+test('a test', a)