aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/common/9 header install/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/common/9 header install/meson.build')
-rw-r--r--meson/test cases/common/9 header install/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson/test cases/common/9 header install/meson.build b/meson/test cases/common/9 header install/meson.build
new file mode 100644
index 000000000..891cb596b
--- /dev/null
+++ b/meson/test cases/common/9 header install/meson.build
@@ -0,0 +1,12 @@
+project('header install')
+
+as_array = ['subdir.h']
+
+subdir('vanishing_subdir')
+subdir('sub')
+
+h1 = install_headers('rootdir.h')
+h2 = install_headers(as_array, subdir : 'subdir')
+h3 = install_headers(subheader)
+h4 = install_headers(disabler())
+