aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/common/97 find program path/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/common/97 find program path/meson.build')
-rw-r--r--meson/test cases/common/97 find program path/meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/meson/test cases/common/97 find program path/meson.build b/meson/test cases/common/97 find program path/meson.build
new file mode 100644
index 000000000..0a812499a
--- /dev/null
+++ b/meson/test cases/common/97 find program path/meson.build
@@ -0,0 +1,22 @@
+project('find program', 'c')
+
+python = import('python3').find_python()
+
+# Source file via string
+prog = find_program('program.py')
+# Source file via files()
+progf = files('program.py')
+# Built file
+py = configure_file(input : 'program.py',
+ output : 'builtprogram.py',
+ configuration : configuration_data())
+
+foreach f : [prog, progf, py, find_program(py), find_program(progf)]
+ ret = run_command(python, f)
+ assert(ret.returncode() == 0, 'can\'t manually run @0@'.format(prog.path()))
+ assert(ret.stdout().strip() == 'Found', 'wrong output from manually-run @0@'.format(prog.path()))
+
+ ret = run_command(f)
+ assert(ret.returncode() == 0, 'can\'t run @0@'.format(prog.path()))
+ assert(ret.stdout().strip() == 'Found', 'wrong output from @0@'.format(prog.path()))
+endforeach