aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/failing test/5 tap tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/failing test/5 tap tests/meson.build')
-rw-r--r--meson/test cases/failing test/5 tap tests/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson/test cases/failing test/5 tap tests/meson.build b/meson/test cases/failing test/5 tap tests/meson.build
new file mode 100644
index 000000000..664ac34d2
--- /dev/null
+++ b/meson/test cases/failing test/5 tap tests/meson.build
@@ -0,0 +1,9 @@
+project('test features', 'c')
+
+tester = executable('tester', 'tester.c')
+test_with_status = executable('test-with-status', 'tester_with_status.c')
+test('nonzero return code no tests', tester, args : [], protocol: 'tap')
+test('nonzero return code with tests', test_with_status, protocol: 'tap')
+test('missing test', tester, args : ['1..1'], protocol: 'tap')
+test('incorrect skip', tester, args : ['1..1 # skip\nok 1'], protocol: 'tap')
+test('partially skipped', tester, args : ['not ok 1\nok 2 # skip'], protocol: 'tap')