aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/failing/27 noprog use/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/failing/27 noprog use/meson.build')
-rw-r--r--meson/test cases/failing/27 noprog use/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson/test cases/failing/27 noprog use/meson.build b/meson/test cases/failing/27 noprog use/meson.build
new file mode 100644
index 000000000..e4de42fbd
--- /dev/null
+++ b/meson/test cases/failing/27 noprog use/meson.build
@@ -0,0 +1,9 @@
+project('using not found exe', 'c')
+
+nope = find_program('nonexisting', required : false)
+
+custom_target( 'aa',
+ input: 'meson.build',
+ output: 'foobar',
+ command: [nope, '@INPUT@', '@OUTPUT@']
+)