aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/failing/32 exe static shared/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/failing/32 exe static shared/meson.build')
-rw-r--r--meson/test cases/failing/32 exe static shared/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson/test cases/failing/32 exe static shared/meson.build b/meson/test cases/failing/32 exe static shared/meson.build
new file mode 100644
index 000000000..2ae512583
--- /dev/null
+++ b/meson/test cases/failing/32 exe static shared/meson.build
@@ -0,0 +1,11 @@
+project('statchain', 'c')
+
+host_system = host_machine.system()
+if host_system == 'windows' or host_system == 'darwin'
+ error('MESON_SKIP_TEST test only fails on Linux and BSD')
+endif
+
+statlib = static_library('stat', 'stat.c', pic : false)
+shlib2 = shared_library('shr2', 'shlib2.c', link_with : statlib)
+exe = executable('prog', 'prog.c', link_with : shlib2)
+test('runtest', exe)