aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/fortran/10 find library/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/fortran/10 find library/meson.build')
-rw-r--r--meson/test cases/fortran/10 find library/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson/test cases/fortran/10 find library/meson.build b/meson/test cases/fortran/10 find library/meson.build
new file mode 100644
index 000000000..2a2ef3111
--- /dev/null
+++ b/meson/test cases/fortran/10 find library/meson.build
@@ -0,0 +1,13 @@
+project('find fortran library', 'fortran')
+
+fc = meson.get_compiler('fortran')
+
+sources = ['main.f90', 'gzip.f90']
+zlib = fc.find_library('z', required: false)
+
+if not zlib.found()
+ error('MESON_SKIP_TEST: Z library not available.')
+endif
+
+exe = executable('zlibtest', sources, dependencies : zlib)
+test('testzlib', exe)