aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/frameworks/1 boost/partial_dep/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/frameworks/1 boost/partial_dep/meson.build')
-rw-r--r--meson/test cases/frameworks/1 boost/partial_dep/meson.build31
1 files changed, 31 insertions, 0 deletions
diff --git a/meson/test cases/frameworks/1 boost/partial_dep/meson.build b/meson/test cases/frameworks/1 boost/partial_dep/meson.build
new file mode 100644
index 000000000..9d481bbfe
--- /dev/null
+++ b/meson/test cases/frameworks/1 boost/partial_dep/meson.build
@@ -0,0 +1,31 @@
+# Copyright © 2018 Intel Corporation
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+dep_boost = dependency('boost')
+dep_boost_headers = dep_boost.partial_dependency(compile_args : true)
+
+libfoo = static_library(
+ 'foo',
+ 'foo.cpp',
+ dependencies : dep_boost_headers,
+)
+
+exe_external_dep = executable(
+ 'external_dep',
+ 'main.cpp',
+ dependencies : dep_boost,
+ link_with : libfoo
+)
+
+test('External Dependency', exe_external_dep)