aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/frameworks/23 hotdoc/doc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/frameworks/23 hotdoc/doc/meson.build')
-rw-r--r--meson/test cases/frameworks/23 hotdoc/doc/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/meson/test cases/frameworks/23 hotdoc/doc/meson.build b/meson/test cases/frameworks/23 hotdoc/doc/meson.build
new file mode 100644
index 000000000..a09bff08d
--- /dev/null
+++ b/meson/test cases/frameworks/23 hotdoc/doc/meson.build
@@ -0,0 +1,19 @@
+hotdoc = import('hotdoc')
+
+target = hotdoc.generate_doc(
+ 'foobar',
+ c_smart_index: true,
+ project_version: '0.1',
+ sitemap: 'sitemap.txt',
+ index: 'index.md',
+ c_sources: files('../../10 gtk-doc/include/foo.h'),
+ languages: ['c'],
+ install: true,
+)
+
+assert(target.config_path() == target.full_path() + '.json',
+ 'Hotdoc config paths do not match.'
+)
+
+assert(hotdoc.has_extensions('search') == true,
+ 'Extension "search" provided by hotdoc core should always be found')