aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/frameworks/34 gir static lib/subdir/gir/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/frameworks/34 gir static lib/subdir/gir/meson.build')
-rw-r--r--meson/test cases/frameworks/34 gir static lib/subdir/gir/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/meson/test cases/frameworks/34 gir static lib/subdir/gir/meson.build b/meson/test cases/frameworks/34 gir static lib/subdir/gir/meson.build
new file mode 100644
index 000000000..b26f04e47
--- /dev/null
+++ b/meson/test cases/frameworks/34 gir static lib/subdir/gir/meson.build
@@ -0,0 +1,28 @@
+libsources = ['meson-subsample.c', 'meson-subsample.h']
+
+girlib = shared_library(
+ 'girlib',
+ sources : libsources,
+ dependencies : [gobj, statichelper_dep],
+ install : true
+)
+
+girexe = executable(
+ 'girprog',
+ sources : 'prog.c',
+ dependencies : [gobj, statichelper_dep],
+ link_with : girlib
+)
+
+gnome.generate_gir(
+ girlib, statichelper_lib,
+ sources : [ libsources, statichelper_sources ],
+ nsversion : '1.0',
+ namespace : 'Meson',
+ symbol_prefix : 'meson_',
+ identifier_prefix : 'Meson',
+ includes : ['GObject-2.0'],
+ install : true
+)
+
+test('gobject introspection/subproject/c', girexe)