aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/python3/3 cython/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/python3/3 cython/meson.build')
-rw-r--r--meson/test cases/python3/3 cython/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/meson/test cases/python3/3 cython/meson.build b/meson/test cases/python3/3 cython/meson.build
new file mode 100644
index 000000000..753b906cf
--- /dev/null
+++ b/meson/test cases/python3/3 cython/meson.build
@@ -0,0 +1,20 @@
+project('cython', 'c',
+ default_options : ['warning_level=3'])
+
+cython = find_program('cython3', required : false)
+py3_dep = dependency('python3', required : false)
+
+if cython.found() and py3_dep.found()
+ py3_dep = dependency('python3')
+ py3_mod = import('python3')
+ py3 = py3_mod.find_python()
+ subdir('libdir')
+
+ test('cython tester',
+ py3,
+ args : files('cytest.py'),
+ env : ['PYTHONPATH=' + pydir]
+ )
+else
+ error('MESON_SKIP_TEST: Cython3 or Python3 libraries not found, skipping test.')
+endif