aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/rust/14 external libm/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/rust/14 external libm/meson.build')
-rw-r--r--meson/test cases/rust/14 external libm/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/meson/test cases/rust/14 external libm/meson.build b/meson/test cases/rust/14 external libm/meson.build
new file mode 100644
index 000000000..20af83c87
--- /dev/null
+++ b/meson/test cases/rust/14 external libm/meson.build
@@ -0,0 +1,24 @@
+project('rust linking to libm', 'c', 'rust')
+
+if host_machine.system() == 'darwin'
+ error('MESON_SKIP_TEST: doesnt work right on macos, please fix!')
+endif
+
+cc = meson.get_compiler('c')
+dep_m = cc.find_library('m', required : false, static : get_option('static'))
+if not dep_m.found()
+ error('MESON_SKIP_TEST: Could not find a @0@ libm'.format(get_option('static') ? 'static' : 'shared'))
+endif
+
+librs_math = static_library(
+ 'rs_math',
+ 'rs_math.rs',
+ dependencies : [dep_m],
+)
+
+e = executable(
+ 'prog', 'prog.rs',
+ link_with : [librs_math],
+)
+
+test('cdepstest', e)