aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/rust/4 polyglot/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/rust/4 polyglot/meson.build')
-rw-r--r--meson/test cases/rust/4 polyglot/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson/test cases/rust/4 polyglot/meson.build b/meson/test cases/rust/4 polyglot/meson.build
new file mode 100644
index 000000000..4e96679f6
--- /dev/null
+++ b/meson/test cases/rust/4 polyglot/meson.build
@@ -0,0 +1,9 @@
+project('rust and c polyglot executable', 'c', 'rust')
+
+if host_machine.system() == 'darwin'
+ error('MESON_SKIP_TEST: doesnt work right on macos, please fix!')
+endif
+
+l = shared_library('stuff', 'stuff.rs', rust_crate_type: 'cdylib', install : true)
+e = executable('prog', 'prog.c', link_with : l, install : true)
+test('polyglottest', e)