aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/rust/5 polyglot static/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/rust/5 polyglot static/meson.build')
-rw-r--r--meson/test cases/rust/5 polyglot static/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/meson/test cases/rust/5 polyglot static/meson.build b/meson/test cases/rust/5 polyglot static/meson.build
new file mode 100644
index 000000000..a6e9550b6
--- /dev/null
+++ b/meson/test cases/rust/5 polyglot static/meson.build
@@ -0,0 +1,17 @@
+project('static rust and c polyglot executable', 'c', 'rust')
+
+deps = [
+ meson.get_compiler('c').find_library('dl', required: false),
+ meson.get_compiler('c').find_library('m', required: false),
+ dependency('threads'),
+]
+
+extra_winlibs = meson.get_compiler('c').get_id() in ['msvc', 'clang-cl'] ? ['userenv.lib', 'ws2_32.lib'] : []
+
+l = static_library('stuff', 'stuff.rs', rust_crate_type : 'staticlib', install : true)
+e = executable('prog', 'prog.c',
+ dependencies: deps,
+ link_with : l,
+ link_args: extra_winlibs,
+ install : true)
+test('polyglottest', e)