aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/unit/11 cross prog/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/unit/11 cross prog/meson.build')
-rw-r--r--meson/test cases/unit/11 cross prog/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/meson/test cases/unit/11 cross prog/meson.build b/meson/test cases/unit/11 cross prog/meson.build
new file mode 100644
index 000000000..a7adeb284
--- /dev/null
+++ b/meson/test cases/unit/11 cross prog/meson.build
@@ -0,0 +1,16 @@
+project('cross find program', 'c')
+
+native_exe = find_program('sometool.py', native : true)
+cross_exe = find_program('sometool.py')
+cross_other_exe = find_program('someothertool.py')
+
+native_out = run_command(native_exe).stdout().strip()
+cross_out = run_command(cross_exe).stdout().strip()
+cross_other_out = run_command(cross_other_exe).stdout().strip()
+
+assert(native_out == 'native',
+ 'Native output incorrect:' + native_out)
+assert(cross_out == 'cross',
+ 'Cross output incorrect:' + cross_out)
+assert(cross_out == cross_other_out,
+ 'Cross output incorrect:' + cross_other_out)