aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/unit/58 pkg_config_path option/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/test cases/unit/58 pkg_config_path option/meson.build')
-rw-r--r--meson/test cases/unit/58 pkg_config_path option/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson/test cases/unit/58 pkg_config_path option/meson.build b/meson/test cases/unit/58 pkg_config_path option/meson.build
new file mode 100644
index 000000000..f9ceead06
--- /dev/null
+++ b/meson/test cases/unit/58 pkg_config_path option/meson.build
@@ -0,0 +1,7 @@
+project('pkg_config_path option')
+
+build = dependency('totally_made_up_dep', native: true, method : 'pkg-config')
+host = dependency('totally_made_up_dep', native: false, method : 'pkg-config')
+
+assert(build.version() == '4.5.6', 'wrong version for build machine dependency')
+assert(host.version() == '1.2.3', 'wrong version for host machine dependency')