summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 21754ee..c235b81 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -40,6 +40,7 @@ target_link_libraries(${TARGET_LIBSM} afbwsc ${link_libraries} ${libsm_depends_L
set_target_properties(${TARGET_LIBSM}
PROPERTIES
VERSION ${PROJECT_VERSION}
+ SOVERSION ${MAJOR_VERSION}.${MINER_VERSION}
)
if(DEFINED CMAKE_INSTALL_LIBDIR)