summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 1a34347..21754ee 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -37,6 +37,11 @@ endif(DEFINED DEBUGMODE)
include_directories(${TARGET_LIBSM} ${libsm_depends_INCLUDE_DIRS})
target_link_libraries(${TARGET_LIBSM} afbwsc ${link_libraries} ${libsm_depends_LIBRARIES})
+set_target_properties(${TARGET_LIBSM}
+ PROPERTIES
+ VERSION ${PROJECT_VERSION}
+)
+
if(DEFINED CMAKE_INSTALL_LIBDIR)
INSTALL(TARGETS ${TARGET_LIBSM}
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})