summaryrefslogtreecommitdiffstats
path: root/demo3/common/agl-service-windowmanager/policy_manager/stm/stub/CMakeLists.txt
diff options
context:
space:
mode:
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>2018-11-14 12:39:54 +0900
committerzheng_wenlong <wenlong_zheng@nexty-ele.com>2018-11-14 12:39:54 +0900
commit5f9be1b9c8e6a4b6d25d64e6f5ec28deb0525854 (patch)
treef1df13a6601a8065c3ecd5c73065b9d768b56c77 /demo3/common/agl-service-windowmanager/policy_manager/stm/stub/CMakeLists.txt
parent5025144c46ad116ba2f7b0506fb9b5c0b2b7a3e4 (diff)
Add windowmanager-service and libraries
Add windowmanager-service and libraries. Change-Id: I838b149ee8a62c0dbc6cb98e1fe8e45929e19140 Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com>
Diffstat (limited to 'demo3/common/agl-service-windowmanager/policy_manager/stm/stub/CMakeLists.txt')
-rw-r--r--demo3/common/agl-service-windowmanager/policy_manager/stm/stub/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/demo3/common/agl-service-windowmanager/policy_manager/stm/stub/CMakeLists.txt b/demo3/common/agl-service-windowmanager/policy_manager/stm/stub/CMakeLists.txt
new file mode 100644
index 0000000..81f0e00
--- /dev/null
+++ b/demo3/common/agl-service-windowmanager/policy_manager/stm/stub/CMakeLists.txt
@@ -0,0 +1,44 @@
+#
+# Copyright (c) 2017 TOYOTA MOTOR CORPORATION
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+set(TARGETS_STM pmstm)
+
+add_library(${TARGETS_STM}
+ STATIC
+ ./stm_inner.c
+)
+
+target_include_directories(${TARGETS_STM}
+ PRIVATE
+ ../
+ ./
+)
+
+target_compile_definitions(${TARGETS_STM}
+ PRIVATE
+ _GNU_SOURCE
+)
+
+target_compile_options(${TARGETS_STM}
+ PRIVATE
+ -Wall -Wextra -Wno-unused-parameter -Wno-comment)
+
+set_target_properties(${TARGETS_STM}
+ PROPERTIES
+ C_EXTENSIONS OFF
+ C_STANDARD 99
+ C_STANDARD_REQUIRED ON
+)