aboutsummaryrefslogtreecommitdiffstats
path: root/meta-application-manager/recipes-application-framework/app-core/files/0002-remove-efl-appcore-efl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-application-manager/recipes-application-framework/app-core/files/0002-remove-efl-appcore-efl.patch')
-rw-r--r--meta-application-manager/recipes-application-framework/app-core/files/0002-remove-efl-appcore-efl.patch813
1 files changed, 813 insertions, 0 deletions
diff --git a/meta-application-manager/recipes-application-framework/app-core/files/0002-remove-efl-appcore-efl.patch b/meta-application-manager/recipes-application-framework/app-core/files/0002-remove-efl-appcore-efl.patch
new file mode 100644
index 0000000..1ebdd8b
--- /dev/null
+++ b/meta-application-manager/recipes-application-framework/app-core/files/0002-remove-efl-appcore-efl.patch
@@ -0,0 +1,813 @@
+--- a/src/appcore-efl.c
++++ b/src/appcore-efl.c
+@@ -30,19 +30,21 @@
+ #include <stdlib.h>
+
+ #ifdef WAYLAND
+-#include <Ecore_Wayland.h>
++//#include <Ecore_Wayland.h>
+ #endif
+
+ #ifdef X11
+ #include <X11/Xatom.h>
+ #include <X11/Xlib.h>
+-#include <Ecore_X.h>
++//#include <Ecore_X.h>
+ #endif
+
+-#include <Ecore.h>
+-#include <Ecore_Evas.h>
+-#include <Ecore_Input_Evas.h>
+-#include <Elementary.h>
++/*
++ * #include <Ecore.h>
++ * #include <Ecore_Evas.h>
++ * #include <Ecore_Input_Evas.h>
++ * #include <Elementary.h>
++ */
+ #include <glib-object.h>
+ #include <malloc.h>
+ #include <glib.h>
+@@ -83,12 +85,12 @@
+ const char *name;
+ enum app_state state;
+
+- Ecore_Event_Handler *hshow;
+- Ecore_Event_Handler *hhide;
+- Ecore_Event_Handler *hvchange;
+- Ecore_Event_Handler *hcmsg; /* WM_ROTATE */
++/* Ecore_Event_Handler *hshow;
++ * Ecore_Event_Handler *hhide;
++ Ecore_Event_Handler *hvchange; */
++// Ecore_Event_Handler *hcmsg; /* WM_ROTATE */
+
+- Ecore_Timer *mftimer; /* Ecore Timer for memory flushing */
++// Ecore_Timer *mftimer; /* Ecore Timer for memory flushing */
+
+ struct appcore_ops *ops;
+ void (*mfcb) (void); /* Memory Flushing Callback */
+@@ -129,7 +131,7 @@
+ };
+
+ static struct ui_wm_rotate wm_rotate;
+-static Eina_Bool __visibility_cb(void *data, int type, void *event);
++//static Eina_Bool __visibility_cb(void *data, int type, void *event);
+
+ static inline int send_int(int fd, int val)
+ {
+@@ -282,16 +284,16 @@
+ GSList *g_winnode_list = NULL;
+
+ #if defined(MEMORY_FLUSH_ACTIVATE)
+-static Eina_Bool __appcore_memory_flush_cb(void *data)
+-{
+- struct ui_priv *ui = (struct ui_priv *)data;
+-
+- appcore_flush_memory();
+- ui->mftimer = NULL;
+-
+- return ECORE_CALLBACK_CANCEL;
+-}
+-
++/* static Eina_Bool __appcore_memory_flush_cb(void *data)
++ * {
++ * struct ui_priv *ui = (struct ui_priv *)data;
++ *
++ * appcore_flush_memory();
++ * ui->mftimer = NULL;
++ *
++ * return ECORE_CALLBACK_CANCEL;
++ * }
++ */
+ static int __appcore_low_memory_post_cb(struct ui_priv *ui)
+ {
+ if (ui->state == AS_PAUSED) {
+@@ -305,15 +307,16 @@
+
+ static void __appcore_timer_add(struct ui_priv *ui)
+ {
+- ui->mftimer = ecore_timer_add(5, __appcore_memory_flush_cb, ui);
++// ui->mftimer = ecore_timer_add(5, __appcore_memory_flush_cb, ui);
+ }
+
+ static void __appcore_timer_del(struct ui_priv *ui)
+ {
+- if (ui->mftimer) {
+- ecore_timer_del(ui->mftimer);
+- ui->mftimer = NULL;
+- }
++/* if (ui->mftimer) {
++ * ecore_timer_del(ui->mftimer);
++ * ui->mftimer = NULL;
++ * }
++ */
+ }
+
+ #else
+@@ -331,7 +334,7 @@
+ static void __appcore_efl_memory_flush_cb(void)
+ {
+ _DBG("[APP %d] __appcore_efl_memory_flush_cb()", _pid);
+- elm_cache_all_flush();
++// elm_cache_all_flush();
+ }
+
+ static void __do_app(enum app_event event, void *data, bundle * b)
+@@ -360,7 +363,7 @@
+ if (event == AE_TERMINATE) {
+ _DBG("[APP %d] TERMINATE", _pid);
+ ui->state = AS_DYING;
+- elm_exit();
++// elm_exit();
+ return;
+ }
+
+@@ -543,236 +546,238 @@
+ }
+
+ /* WM_ROTATE */
+-#ifdef X11
+-static Ecore_X_Atom _WM_WINDOW_ROTATION_SUPPORTED = 0;
+-static Ecore_X_Atom _WM_WINDOW_ROTATION_CHANGE_REQUEST = 0;
+-
+-static int __check_wm_rotation_support(void)
+-{
+- _DBG("Disable window manager rotation");
+- return -1;
+-
+- Ecore_X_Window root, win, win2;
+- int ret;
+-
+- if (!_WM_WINDOW_ROTATION_SUPPORTED) {
+- _WM_WINDOW_ROTATION_SUPPORTED =
+- ecore_x_atom_get("_E_WINDOW_ROTATION_SUPPORTED");
+- }
+-
+- if (!_WM_WINDOW_ROTATION_CHANGE_REQUEST) {
+- _WM_WINDOW_ROTATION_CHANGE_REQUEST =
+- ecore_x_atom_get("_E_WINDOW_ROTATION_CHANGE_REQUEST");
+- }
+-
+- root = ecore_x_window_root_first_get();
+- ret = ecore_x_window_prop_xid_get(root,
+- _WM_WINDOW_ROTATION_SUPPORTED,
+- ECORE_X_ATOM_WINDOW,
+- &win, 1);
+- if ((ret == 1) && (win))
+- {
+- ret = ecore_x_window_prop_xid_get(win,
+- _WM_WINDOW_ROTATION_SUPPORTED,
+- ECORE_X_ATOM_WINDOW,
+- &win2, 1);
+- if ((ret == 1) && (win2 == win))
+- return 0;
+- }
+-
+- return -1;
+-}
+-
+-static void __set_wm_rotation_support(unsigned int win, unsigned int set)
+-{
+- GSList *iter = NULL;
+- struct win_node *entry = NULL;
+-
+- if (0 == win) {
+- for (iter = g_winnode_list; iter != NULL; iter = g_slist_next(iter)) {
+- entry = iter->data;
+- if (entry->win) {
+- ecore_x_window_prop_card32_set(entry->win,
+- _WM_WINDOW_ROTATION_SUPPORTED,
+- &set, 1);
+- }
+- }
+- } else {
+- ecore_x_window_prop_card32_set(win,
+- _WM_WINDOW_ROTATION_SUPPORTED,
+- &set, 1);
+- }
+-}
+-
+-Ecore_X_Atom atom_parent;
+-#endif
+-
+-static Eina_Bool __show_cb(void *data, int type, void *event)
+-{
+-#ifdef WAYLAND
+- /*Ecore_Wl_Event_Window_Activate *ev;
+-
+- ev = event;
+-
+- if (ev->parent_win != 0)
+- {
+- // This is child window. Skip!!!
+- return ECORE_CALLBACK_PASS_ON;
+- }*/
+-
+- _DBG("[EVENT_TEST][EVENT] GET SHOW EVENT!!!.\n");
+-
+- /*if (!__exist_win((unsigned int)ev->win))
+- __add_win((unsigned int)ev->win);
+- else
+- __update_win((unsigned int)ev->win, FALSE);*/
+-
+- __visibility_cb(data, type, event);
+-#else
+- Ecore_X_Event_Window_Show *ev;
+- int ret;
+- Ecore_X_Window parent;
+-
+- ev = event;
+-
+- ret = ecore_x_window_prop_window_get(ev->win, atom_parent, &parent, 1);
+- if (ret != 1)
+- {
+- // This is child window. Skip!!!
+- return ECORE_CALLBACK_PASS_ON;
+- }
+-
+- _DBG("[EVENT_TEST][EVENT] GET SHOW EVENT!!!. WIN:%x\n", ev->win);
+-
+- if (!__exist_win((unsigned int)ev->win)) {
+- /* WM_ROTATE */
+- if ((priv.wm_rot_supported) && (1 == priv.rot_started)) {
+- __set_wm_rotation_support(ev->win, 1);
+- }
+- __add_win((unsigned int)ev->win);
+- }
+- else
+- __update_win((unsigned int)ev->win, FALSE);
+-#endif
+-
+- return ECORE_CALLBACK_RENEW;
+-}
+-
+-static Eina_Bool __hide_cb(void *data, int type, void *event)
+-{
+-#ifdef WAYLAND
+- //Ecore_Wl_Event_Window_Deactivate *ev;
+- int bvisibility = 0;
+-
+- //ev = event;
+-
+- _DBG("[EVENT_TEST][EVENT] GET HIDE EVENT!!!.\n");
+-
+- /*if (__exist_win((unsigned int)ev->win)) {
+- __delete_win((unsigned int)ev->win);
+-
+- bvisibility = __check_visible();
+- if (!bvisibility && b_active == 1) {
+- _DBG(" Go to Pasue state \n");
+- b_active = 0;
+- __do_app(AE_PAUSE, data, NULL);
+- }
+- }*/
+-#else
+- Ecore_X_Event_Window_Hide *ev;
+- int bvisibility = 0;
+-
+- ev = event;
+-
+- _DBG("[EVENT_TEST][EVENT] GET HIDE EVENT!!!. WIN:%x\n", ev->win);
+-
+- if (__exist_win((unsigned int)ev->win)) {
+- __delete_win((unsigned int)ev->win);
+-
+- bvisibility = __check_visible();
+- if (!bvisibility && b_active == 1) {
+- _DBG(" Go to Pasue state \n");
+- b_active = 0;
+- __do_app(AE_PAUSE, data, NULL);
+- }
+- }
+-#endif
+-
+- return ECORE_CALLBACK_RENEW;
+-}
+-
+-static Eina_Bool __visibility_cb(void *data, int type, void *event)
+-{
+-#ifdef WAYLAND
+- //Ecore_Wl_Event_Window_Activate *ev;
+- int bvisibility = 0;
+-
+- //ev = event;
+-
+- //__update_win((unsigned int)ev->win, ev->fobscured);
+-#else
+- Ecore_X_Event_Window_Visibility_Change *ev;
+- int bvisibility = 0;
+-
+- ev = event;
+-
+- __update_win((unsigned int)ev->win, ev->fully_obscured);
+-#endif
+- bvisibility = __check_visible();
+-
+- if (bvisibility && b_active == 0) {
+- _DBG(" Go to Resume state\n");
+- b_active = 1;
+- __do_app(AE_RESUME, data, NULL);
+-
+- } else if (!bvisibility && b_active == 1) {
+- _DBG(" Go to Pasue state \n");
+- b_active = 0;
+- __do_app(AE_PAUSE, data, NULL);
+- } else
+- _DBG(" No change state \n");
+-
+- return ECORE_CALLBACK_RENEW;
+-
+-}
+-
+-#ifdef X11
++//#ifdef X11
++/*
++ * static Ecore_X_Atom _WM_WINDOW_ROTATION_SUPPORTED = 0;
++ * static Ecore_X_Atom _WM_WINDOW_ROTATION_CHANGE_REQUEST = 0;
++ *
++ * static int __check_wm_rotation_support(void)
++ * {
++ * _DBG("Disable window manager rotation");
++ * return -1;
++ *
++ * Ecore_X_Window root, win, win2;
++ * int ret;
++ *
++ * if (!_WM_WINDOW_ROTATION_SUPPORTED) {
++ * _WM_WINDOW_ROTATION_SUPPORTED =
++ * ecore_x_atom_get("_E_WINDOW_ROTATION_SUPPORTED");
++ * }
++ *
++ * if (!_WM_WINDOW_ROTATION_CHANGE_REQUEST) {
++ * _WM_WINDOW_ROTATION_CHANGE_REQUEST =
++ * ecore_x_atom_get("_E_WINDOW_ROTATION_CHANGE_REQUEST");
++ * }
++ *
++ * root = ecore_x_window_root_first_get();
++ * ret = ecore_x_window_prop_xid_get(root,
++ * _WM_WINDOW_ROTATION_SUPPORTED,
++ * ECORE_X_ATOM_WINDOW,
++ * &win, 1);
++ * if ((ret == 1) && (win))
++ * {
++ * ret = ecore_x_window_prop_xid_get(win,
++ * _WM_WINDOW_ROTATION_SUPPORTED,
++ * ECORE_X_ATOM_WINDOW,
++ * &win2, 1);
++ * if ((ret == 1) && (win2 == win))
++ * return 0;
++ * }
++ *
++ * return -1;
++ * }
++ *
++ * static void __set_wm_rotation_support(unsigned int win, unsigned int set)
++ * {
++ * GSList *iter = NULL;
++ * struct win_node *entry = NULL;
++ *
++ * if (0 == win) {
++ * for (iter = g_winnode_list; iter != NULL; iter = g_slist_next(iter)) {
++ * entry = iter->data;
++ * if (entry->win) {
++ * ecore_x_window_prop_card32_set(entry->win,
++ * _WM_WINDOW_ROTATION_SUPPORTED,
++ * &set, 1);
++ * }
++ * }
++ * } else {
++ * ecore_x_window_prop_card32_set(win,
++ * _WM_WINDOW_ROTATION_SUPPORTED, *
++ * &set, 1);
++ * }
++ * }
++ *
++ * Ecore_X_Atom atom_parent;
++#endif
++
++/* static Eina_Bool __show_cb(void *data, int type, void *event)
++ * {
++ * #ifdef WAYLAND
++ * Ecore_Wl_Event_Window_Activate *ev;
++ *
++ * ev = event;
++ *
++ * if (ev->parent_win != 0)
++ * {
++ * // This is child window. Skip!!!
++ * return ECORE_CALLBACK_PASS_ON;
++ * }
++ *
++ * _DBG("[EVENT_TEST][EVENT] GET SHOW EVENT!!!.\n");
++ *
++ * if (!__exist_win((unsigned int)ev->win))
++ * __add_win((unsigned int)ev->win);
++ * else
++ * __update_win((unsigned int)ev->win, FALSE);
++ *
++ * __visibility_cb(data, type, event);
++ * #else
++ * Ecore_X_Event_Window_Show *ev;
++ * int ret;
++ * Ecore_X_Window parent;
++ *
++ * ev = event;
++ *
++ * ret = ecore_x_window_prop_window_get(ev->win, atom_parent, &parent, 1);
++ * if (ret != 1)
++ * {
++ * // This is child window. Skip!!!
++ * return ECORE_CALLBACK_PASS_ON;
++ * }
++ *
++ * _DBG("[EVENT_TEST][EVENT] GET SHOW EVENT!!!. WIN:%x\n", ev->win);
++ */
++// if (!__exist_win((unsigned int)ev->win)) {
++// /* WM_ROTATE */
++/* if ((priv.wm_rot_supported) && (1 == priv.rot_started)) {
++ * __set_wm_rotation_support(ev->win, 1);
++ * }
++ * __add_win((unsigned int)ev->win);
++ * }
++ * else
++ * __update_win((unsigned int)ev->win, FALSE);
++ * #endif
++ *
++ * return ECORE_CALLBACK_RENEW;
++ * }
++ */
++/* static Eina_Bool __hide_cb(void *data, int type, void *event)
++ * {
++ * #ifdef WAYLAND
++ * //Ecore_Wl_Event_Window_Deactivate *ev;
++ * int bvisibility = 0;
++ *
++ * //ev = event;
++ *
++ * _DBG("[EVENT_TEST][EVENT] GET HIDE EVENT!!!.\n");
++ *
++ * if (__exist_win((unsigned int)ev->win)) {
++ * __delete_win((unsigned int)ev->win);
++ *
++ * bvisibility = __check_visible();
++ * if (!bvisibility && b_active == 1) {
++ * _DBG(" Go to Pasue state \n");
++ * b_active = 0;
++ * __do_app(AE_PAUSE, data, NULL);
++ * }
++ * }
++ * #else
++ * Ecore_X_Event_Window_Hide *ev;
++ * int bvisibility = 0;
++ *
++ * ev = event;
++ *
++ * _DBG("[EVENT_TEST][EVENT] GET HIDE EVENT!!!. WIN:%x\n", ev->win);
++ *
++ * if (__exist_win((unsigned int)ev->win)) {
++ * __delete_win((unsigned int)ev->win);
++ *
++ * bvisibility = __check_visible();
++ * if (!bvisibility && b_active == 1) {
++ * _DBG(" Go to Pasue state \n");
++ * b_active = 0;
++ * __do_app(AE_PAUSE, data, NULL);
++ * }
++ * }
++ * #endif
++ *
++ * return ECORE_CALLBACK_RENEW;
++ * }
++ */
++/* static Eina_Bool __visibility_cb(void *data, int type, void *event)
++ * {
++ * #ifdef WAYLAND
++ * //Ecore_Wl_Event_Window_Activate *ev;
++ * int bvisibility = 0;
++ *
++ * //ev = event;
++ *
++ * //__update_win((unsigned int)ev->win, ev->fobscured);
++ * #else
++ * Ecore_X_Event_Window_Visibility_Change *ev;
++ * int bvisibility = 0;
++ *
++ * ev = event;
++ *
++ * __update_win((unsigned int)ev->win, ev->fully_obscured);
++ * #endif
++ * bvisibility = __check_visible();
++ *
++ * if (bvisibility && b_active == 0) {
++ * _DBG(" Go to Resume state\n");
++ * b_active = 1;
++ * __do_app(AE_RESUME, data, NULL);
++ *
++ * } else if (!bvisibility && b_active == 1) {
++ * _DBG(" Go to Pasue state \n");
++ * b_active = 0;
++ * __do_app(AE_PAUSE, data, NULL);
++ * } else
++ * _DBG(" No change state \n");
++ *
++ * return ECORE_CALLBACK_RENEW;
++ *
++ * }
++ */
++//#ifdef X11
+ /* WM_ROTATE */
+-static Eina_Bool __cmsg_cb(void *data, int type, void *event)
+-{
+- struct ui_priv *ui = (struct ui_priv *)data;
+- Ecore_X_Event_Client_Message *e = event;
+-
+- if (!ui) return ECORE_CALLBACK_PASS_ON;
+- if (e->format != 32) return ECORE_CALLBACK_PASS_ON;
+- if (e->message_type == _WM_WINDOW_ROTATION_CHANGE_REQUEST) {
+- if ((0 == ui->wm_rot_supported) ||
+- (0 == ui->rot_started) ||
+- (NULL == ui->rot_cb)) {
+- return ECORE_CALLBACK_PASS_ON;
+- }
+-
+- enum appcore_rm rm;
+- switch (e->data.l[1])
+- {
+- case 0: rm = APPCORE_RM_PORTRAIT_NORMAL; break;
+- case 90: rm = APPCORE_RM_LANDSCAPE_REVERSE; break;
+- case 180: rm = APPCORE_RM_PORTRAIT_REVERSE; break;
+- case 270: rm = APPCORE_RM_LANDSCAPE_NORMAL; break;
+- default: rm = APPCORE_RM_UNKNOWN; break;
+- }
+-
+- ui->rot_mode = rm;
+-
+- if (APPCORE_RM_UNKNOWN != rm) {
+- ui->rot_cb(rm, ui->rot_cb_data);
+- }
+- }
+-
+- return ECORE_CALLBACK_PASS_ON;
+-}
+-#endif
+-
++/* static Eina_Bool __cmsg_cb(void *data, int type, void *event)
++ * {
++ * struct ui_priv *ui = (struct ui_priv *)data;
++ * Ecore_X_Event_Client_Message *e = event;
++ *
++ * if (!ui) return ECORE_CALLBACK_PASS_ON;
++ * if (e->format != 32) return ECORE_CALLBACK_PASS_ON;
++ * if (e->message_type == _WM_WINDOW_ROTATION_CHANGE_REQUEST) {
++ * if ((0 == ui->wm_rot_supported) ||
++ * (0 == ui->rot_started) ||
++ * (NULL == ui->rot_cb)) {
++ * return ECORE_CALLBACK_PASS_ON;
++ * }
++ *
++ * enum appcore_rm rm;
++ * switch (e->data.l[1])
++ * {
++ * case 0: rm = APPCORE_RM_PORTRAIT_NORMAL; break;
++ * case 90: rm = APPCORE_RM_LANDSCAPE_REVERSE; break;
++ * case 180: rm = APPCORE_RM_PORTRAIT_REVERSE; break;
++ * case 270: rm = APPCORE_RM_LANDSCAPE_NORMAL; break;
++ * default: rm = APPCORE_RM_UNKNOWN; break;
++ * }
++ *
++ * ui->rot_mode = rm;
++ *
++ * if (APPCORE_RM_UNKNOWN != rm) {
++ * ui->rot_cb(rm, ui->rot_cb_data);
++ * }
++ * }
++ *
++ * return ECORE_CALLBACK_PASS_ON;
++ * }
++ *
++ * #endif
++ */
+ static void __add_climsg_cb(struct ui_priv *ui)
+ {
+ _ret_if(ui == NULL);
+@@ -782,25 +787,25 @@
+ ui->hhide =
+ ecore_event_handler_add(ECORE_WL_EVENT_WINDOW_DEACTIVATE, __hide_cb, ui);*/
+ #else
+- atom_parent = ecore_x_atom_get("_E_PARENT_BORDER_WINDOW");
+- if (!atom_parent)
+- {
+- // Do Error Handling
+- }
+-
+- ui->hshow =
+- ecore_event_handler_add(ECORE_X_EVENT_WINDOW_SHOW, __show_cb, ui);
+- ui->hhide =
+- ecore_event_handler_add(ECORE_X_EVENT_WINDOW_HIDE, __hide_cb, ui);
+- ui->hvchange =
+- ecore_event_handler_add(ECORE_X_EVENT_WINDOW_VISIBILITY_CHANGE,
+- __visibility_cb, ui);
+-
++/* atom_parent = ecore_x_atom_get("_E_PARENT_BORDER_WINDOW");
++ * if (!atom_parent)
++ * {
++ * // Do Error Handling
++ * }
++ *
++ * ui->hshow =
++ * ecore_event_handler_add(ECORE_X_EVENT_WINDOW_SHOW, __show_cb, ui);
++ * ui->hhide =
++ * ecore_event_handler_add(ECORE_X_EVENT_WINDOW_HIDE, __hide_cb, ui);
++ * ui->hvchange =
++ * ecore_event_handler_add(ECORE_X_EVENT_WINDOW_VISIBILITY_CHANGE,
++ * __visibility_cb, ui);
++ */
+ /* Add client message callback for WM_ROTATE */
+ if(!__check_wm_rotation_support())
+ {
+- ui->hcmsg =
+- ecore_event_handler_add(ECORE_X_EVENT_CLIENT_MESSAGE, __cmsg_cb, ui);
++/* ui->hcmsg =
++ ecore_event_handler_add(ECORE_X_EVENT_CLIENT_MESSAGE, __cmsg_cb, ui); */
+ ui->wm_rot_supported = 1;
+ appcore_set_wm_rotation(&wm_rotate);
+ }
+@@ -819,30 +824,30 @@
+ }
+
+ g_type_init();
+- elm_init(*argc, *argv);
++// elm_init(*argc, *argv);
+
+ hwacc = getenv("HWACC");
+
+ if(hwacc == NULL) {
+- _DBG("elm_config_preferred_engine_set is not called");
++// _DBG("elm_config_preferred_engine_set is not called");
+ } else if(strcmp(hwacc, "USE") == 0) {
+ #ifdef WAYLAND
+- elm_config_preferred_engine_set("wayland_egl");
+- _DBG("elm_config_preferred_engine_set : wayland_egl");
++// elm_config_preferred_engine_set("wayland_egl");
++// _DBG("elm_config_preferred_engine_set : wayland_egl");
+ #else
+- elm_config_preferred_engine_set("opengl_x11");
+- _DBG("elm_config_preferred_engine_set : opengl_x11");
++// elm_config_preferred_engine_set("opengl_x11");
++// _DBG("elm_config_preferred_engine_set : opengl_x11");
+ #endif
+ } else if(strcmp(hwacc, "NOT_USE") == 0) {
+ #ifdef WAYLAND
+- elm_config_preferred_engine_set("wayland_shm");
+- _DBG("elm_config_preferred_engine_set : wayland_shm");
++// elm_config_preferred_engine_set("wayland_shm");
++// _DBG("elm_config_preferred_engine_set : wayland_shm");
+ #else
+- elm_config_preferred_engine_set("software_x11");
+- _DBG("elm_config_preferred_engine_set : software_x11");
++// elm_config_preferred_engine_set("software_x11");
++// _DBG("elm_config_preferred_engine_set : software_x11");
+ #endif
+ } else {
+- _DBG("elm_config_preferred_engine_set is not called");
++// _DBG("elm_config_preferred_engine_set is not called");
+ }
+
+ r = appcore_init(ui->name, &efl_ops, *argc, *argv);
+@@ -875,16 +880,16 @@
+ if (ui->ops && ui->ops->terminate)
+ ui->ops->terminate(ui->ops->data);
+
+- if (ui->hshow)
+- ecore_event_handler_del(ui->hshow);
+- if (ui->hhide)
+- ecore_event_handler_del(ui->hhide);
+- if (ui->hvchange)
+- ecore_event_handler_del(ui->hvchange);
+-
++/* if (ui->hshow)
++ * ecore_event_handler_del(ui->hshow);
++ * if (ui->hhide)
++ * ecore_event_handler_del(ui->hhide);
++ * if (ui->hvchange)
++ * ecore_event_handler_del(ui->hvchange);
++ */
+ __appcore_timer_del(ui);
+
+- elm_shutdown();
++// elm_shutdown();
+ }
+
+ static int __set_data(struct ui_priv *ui, const char *name,
+@@ -913,7 +918,7 @@
+
+ ui->ops = ops;
+
+- ui->mfcb = __appcore_efl_memory_flush_cb;
++// ui->mfcb = __appcore_efl_memory_flush_cb;
+
+ _pid = getpid();
+
+@@ -1025,7 +1030,7 @@
+ return -1;
+ }
+
+- elm_run();
++// elm_run();
+
+ aul_status_update(STATUS_DYING);
+
+
+--- a/src/appcore-rotation.c
++++ b/src/appcore-rotation.c
+@@ -26,25 +26,25 @@
+
+ #include <sensor.h>
+ #include <vconf.h>
+-#include <Ecore.h>
++//#include <Ecore.h>
+ #include "appcore-internal.h"
+
+ #ifdef X11
+-#include <Ecore_X.h>
++//#include <Ecore_X.h>
+ #include <X11/Xlib.h>
+
+ /*Fixme: to be added for wayland works*/
+ #define _MAKE_ATOM(a, s) \
+- do { \
++/* do { \
+ a = ecore_x_atom_get(s); \
+ if (!a) \
+ _ERR("##s creation failed.\n"); \
+ } while(0)
+-
++*/
+ #define STR_ATOM_ROTATION_LOCK "_E_ROTATION_LOCK"
+
+-static Ecore_X_Atom ATOM_ROTATION_LOCK = 0;
+-static Ecore_X_Window root;
++//static Ecore_X_Atom ATOM_ROTATION_LOCK = 0;
++//static Ecore_X_Window root;
+ #endif
+
+ struct rot_s {
+@@ -245,8 +245,8 @@
+
+ #ifdef X11
+ _MAKE_ATOM(ATOM_ROTATION_LOCK, STR_ATOM_ROTATION_LOCK );
+- root = ecore_x_window_root_first_get();
+- XSelectInput(ecore_x_display_get(), root, PropertyChangeMask);
++ /*root = ecore_x_window_root_first_get();
++ XSelectInput(ecore_x_display_get(), root, PropertyChangeMask);*/
+ #endif
+ }
+ return 0;
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -36,9 +36,9 @@
+ SET(HEADERS_common appcore-common.h)
+
+ INCLUDE(FindPkgConfig)
+-SET(APPCORE_PKG_CHECK_MODULES "vconf sensor aul dlog libtzplatform-config ecore")
++SET(APPCORE_PKG_CHECK_MODULES "vconf sensor aul dlog libtzplatform-config")
+ IF (with_x11)
+- SET(APPCORE_PKG_CHECK_MODULES "${APPCORE_PKG_CHECK_MODULES} x11 ecore-x")
++ SET(APPCORE_PKG_CHECK_MODULES "${APPCORE_PKG_CHECK_MODULES} x11")
+ ENDIF (with_x11)
+
+ pkg_check_modules(pkg_common REQUIRED ${APPCORE_PKG_CHECK_MODULES})
+@@ -75,9 +75,9 @@
+ SET(HEADERS_efl appcore-efl.h)
+
+ INCLUDE(FindPkgConfig)
+-SET(APPCORE_PKG_CHECK_MODULES2 "elementary dlog ecore gobject-2.0 glib-2.0 aul")
++SET(APPCORE_PKG_CHECK_MODULES2 "dlog gobject-2.0 glib-2.0 aul")
+ IF (with_x11)
+- SET(APPCORE_PKG_CHECK_MODULES2 "${APPCORE_PKG_CHECK_MODULES2} ecore-x")
++ SET(APPCORE_PKG_CHECK_MODULES2 "${APPCORE_PKG_CHECK_MODULES2} ")
+ ENDIF (with_x11)
+
+ pkg_check_modules(pkg_efl REQUIRED ${APPCORE_PKG_CHECK_MODULES2})
+
+--- a/TC/unit/utc_ApplicationFW_appcore_efl_main_func.c
++++ b/TC/unit/utc_ApplicationFW_appcore_efl_main_func.c
+@@ -19,7 +19,7 @@
+ *
+ */
+ #include <tet_api.h>
+-#include <Elementary.h>
++//#include <Elementary.h>
+ #include <appcore-efl.h>
+
+ static void startup(void);
+@@ -52,7 +52,7 @@
+
+ static int app_reset(bundle *b, void *data)
+ {
+- elm_exit();
++ //elm_exit();
+ return 0;
+ }
+