aboutsummaryrefslogtreecommitdiffstats
path: root/meta-application-manager/recipes-application-framework/aul/files/0001_remove_ttrace_tizen-extension-client.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-application-manager/recipes-application-framework/aul/files/0001_remove_ttrace_tizen-extension-client.patch')
-rw-r--r--meta-application-manager/recipes-application-framework/aul/files/0001_remove_ttrace_tizen-extension-client.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-application-manager/recipes-application-framework/aul/files/0001_remove_ttrace_tizen-extension-client.patch b/meta-application-manager/recipes-application-framework/aul/files/0001_remove_ttrace_tizen-extension-client.patch
new file mode 100644
index 0000000..effbcb6
--- /dev/null
+++ b/meta-application-manager/recipes-application-framework/aul/files/0001_remove_ttrace_tizen-extension-client.patch
@@ -0,0 +1,48 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 088b6d0..7160c32 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -13,9 +13,9 @@ ENDIF (with_x11)
+
+ # Set required packages
+ INCLUDE(FindPkgConfig)
+-SET(AUL-1_LIB_PKG_CHECK_MODULES dlog bundle xdgmime libtzplatform-config pkgmgr-info capi-system-info vconf sqlite3 iniparser gio-2.0 glib-2.0 libxml-2.0 ttrace)
++SET(AUL-1_LIB_PKG_CHECK_MODULES dlog bundle xdgmime libtzplatform-config pkgmgr-info capi-system-info vconf sqlite3 iniparser gio-2.0 glib-2.0 libxml-2.0)
+ IF (with_wayland)
+- pkg_check_modules(libpkgs REQUIRED ${AUL-1_LIB_PKG_CHECK_MODULES} wayland-client tizen-extension-client ecore-wayland)
++ pkg_check_modules(libpkgs REQUIRED ${AUL-1_LIB_PKG_CHECK_MODULES} wayland-client ecore-wayland)
+ ENDIF (with_wayland)
+ IF (with_x11)
+ pkg_check_modules(libpkgs REQUIRED ${AUL-1_LIB_PKG_CHECK_MODULES})
+diff --git a/src/launch.c b/src/launch.c
+index 72d8a9d..3ae466b 100644
+--- a/src/launch.c
++++ b/src/launch.c
+@@ -25,7 +25,7 @@
+ #include <dirent.h>
+ #include <glib.h>
+ #include <gio/gio.h>
+-#include <ttrace.h>
++//#include <ttrace.h>
+
+ #include <bundle_internal.h>
+
+@@ -289,7 +289,7 @@ int app_request_to_launchpad_for_uid(int cmd, const char *appid, bundle *kb, uid
+ int ret = 0;
+ bundle *b;
+
+- traceBegin(TTRACE_TAG_APPLICATION_MANAGER, "AUL:REQ_TO_PAD");
++ //traceBegin(TTRACE_TAG_APPLICATION_MANAGER, "AUL:REQ_TO_PAD");
+ SECURE_LOGD("launch request : %s", appid);
+ if (kb == NULL) {
+ kb = bundle_create();
+@@ -340,7 +340,7 @@ int app_request_to_launchpad_for_uid(int cmd, const char *appid, bundle *kb, uid
+ if (must_free)
+ bundle_free(kb);
+
+- traceEnd(TTRACE_TAG_APPLICATION_MANAGER);
++ //traceEnd(TTRACE_TAG_APPLICATION_MANAGER);
+
+ return ret;
+ }
+