aboutsummaryrefslogtreecommitdiffstats
path: root/meta-application-manager/recipes-application-framework/pkgmgr/files/0003-remove-efl-pkgmgr.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-application-manager/recipes-application-framework/pkgmgr/files/0003-remove-efl-pkgmgr.patch')
-rw-r--r--meta-application-manager/recipes-application-framework/pkgmgr/files/0003-remove-efl-pkgmgr.patch67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta-application-manager/recipes-application-framework/pkgmgr/files/0003-remove-efl-pkgmgr.patch b/meta-application-manager/recipes-application-framework/pkgmgr/files/0003-remove-efl-pkgmgr.patch
new file mode 100644
index 0000000..2a75a56
--- /dev/null
+++ b/meta-application-manager/recipes-application-framework/pkgmgr/files/0003-remove-efl-pkgmgr.patch
@@ -0,0 +1,67 @@
+--- a/tool/pkgmgr-install.c
++++ b/tool/pkgmgr-install.c
+@@ -97,8 +97,7 @@
+
+ gboolean __term(void *data)
+ {
+- ecore_main_loop_quit();
+-
++// ecore_main_loop_quit();
+ return FALSE;
+ }
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -23,7 +23,7 @@
+ INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include ${CMAKE_SOURCE_DIR}/comm )
+
+ INCLUDE(FindPkgConfig)
+-pkg_check_modules(pkgs REQUIRED security-server dlog ecore ail ecore-file pkgmgr-parser pkgmgr-info iniparser libtzplatform-config notification)
++pkg_check_modules(pkgs REQUIRED security-server dlog ail pkgmgr-parser pkgmgr-info iniparser libtzplatform-config notification)
+
+ FOREACH(flag ${pkgs_CFLAGS})
+ SET(EXTRA_CFLAGS "${EXTRA_CFLAGS} ${flag}")
+
+--- a/tool/CMakeLists.txt
++++ b/tool/CMakeLists.txt
+@@ -6,13 +6,13 @@
+
+ INCLUDE(FindPkgConfig)
+
+-pkg_check_modules(pkgs_initdb REQUIRED libsmack ecore dbus-1 ail libxml-2.0 bundle pkgmgr-parser vconf security-server pkgmgr-info libtzplatform-config)
++pkg_check_modules(pkgs_initdb REQUIRED libsmack dbus-1 ail libxml-2.0 bundle pkgmgr-parser vconf security-server pkgmgr-info libtzplatform-config)
+ FOREACH(flag ${pkgs_initdb_CFLAGS})
+ SET(EXTRA_CFLAGS "${EXTRA_CFLAGS} ${flag}")
+ ENDFOREACH(flag)
+
+
+-pkg_check_modules(pkgs_test REQUIRED ecore dbus-1 ail libxml-2.0 bundle pkgmgr-parser vconf security-server pkgmgr-info libtzplatform-config)
++pkg_check_modules(pkgs_test REQUIRED dbus-1 ail libxml-2.0 bundle pkgmgr-parser vconf security-server pkgmgr-info libtzplatform-config)
+ FOREACH(flag ${pkgs_test_CFLAGS})
+ SET(EXTRA_CFLAGS "${EXTRA_CFLAGS} ${flag}")
+ ENDFOREACH(flag)
+
+--- a/server/src/pkgmgr-server.c
++++ b/server/src/pkgmgr-server.c
+@@ -34,8 +34,8 @@
+ #include <fcntl.h>
+ #include <glib.h>
+ #include <signal.h>
+-#include <Ecore.h>
+-#include <Ecore_File.h>
++//#include <Ecore.h>
++//#include <Ecore_File.h>
+ #include <ail.h>
+ #include <pkgmgr-info.h>
+ #include <pkgmgr/pkgmgr_parser.h>
+@@ -1140,7 +1140,7 @@
+ __check_queue_status_for_exit() &&
+ drawing_popup == 0) {
+ if (!getenv("PMS_STANDALONE") && ail_db_update) {
+- ecore_main_loop_quit();
++ //ecore_main_loop_quit();
+ return FALSE;
+ }
+ }
+
+