summaryrefslogtreecommitdiffstats
path: root/bsp/meta-arm/meta-arm-autonomy/recipes-extended/xen/xen_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-arm/meta-arm-autonomy/recipes-extended/xen/xen_%.bbappend')
-rw-r--r--bsp/meta-arm/meta-arm-autonomy/recipes-extended/xen/xen_%.bbappend14
1 files changed, 14 insertions, 0 deletions
diff --git a/bsp/meta-arm/meta-arm-autonomy/recipes-extended/xen/xen_%.bbappend b/bsp/meta-arm/meta-arm-autonomy/recipes-extended/xen/xen_%.bbappend
new file mode 100644
index 00000000..846d2442
--- /dev/null
+++ b/bsp/meta-arm/meta-arm-autonomy/recipes-extended/xen/xen_%.bbappend
@@ -0,0 +1,14 @@
+#
+# Define early console based on board parameters
+#
+
+XEN_CONFIG_EARLY_PRINTK ??= "disable"
+
+EXTRA_OEMAKE += "${@bb.utils.contains('XEN_CONFIG_EARLY_PRINTK', 'disable', \
+ '', ' CONFIG_DEBUG=y CONFIG_EARLY_PRINTK=${XEN_CONFIG_EARLY_PRINTK}',d)}"
+
+# Make Xen machine specific
+# This ensures that sstate is properly handled and that each machine can have
+# its own configuration
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+