summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-bsp/atf/atf-tools_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-freescale/recipes-bsp/atf/atf-tools_git.bb')
-rw-r--r--bsp/meta-freescale/recipes-bsp/atf/atf-tools_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-bsp/atf/atf-tools_git.bb b/bsp/meta-freescale/recipes-bsp/atf/atf-tools_git.bb
new file mode 100644
index 00000000..33ec51c2
--- /dev/null
+++ b/bsp/meta-freescale/recipes-bsp/atf/atf-tools_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Tools for ARM Trusted Firmware, e.g. FIP image creation tool"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://license.rst;md5=e927e02bca647e14efd87e9e914b2443"
+
+SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/atf;nobranch=1"
+SRCREV = "7d748e6f0ec652ba7c43733dc67a3d0b0217390a"
+
+S = "${WORKDIR}/git"
+
+DEPENDS += "openssl"
+
+EXTRA_OEMAKE = "fiptool V=1 HOSTCC='${CC} ${CPPFLAGS} ${CFLAGS} ${LDFLAGS}'"
+
+do_install () {
+ install -m 0755 -d ${D}/${bindir}
+ install -m 0755 ${S}/tools/fiptool/fiptool ${D}/${bindir}/
+}
+
+BBCLASSEXTEND = "native"