summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.16.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-freescale/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.16.0.bb')
-rw-r--r--bsp/meta-freescale/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.16.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.16.0.bb b/bsp/meta-freescale/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.16.0.bb
new file mode 100644
index 00000000..67dbc8da
--- /dev/null
+++ b/bsp/meta-freescale/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.16.0.bb
@@ -0,0 +1,34 @@
+# Copyright 2017-2018 NXP
+
+DESCRIPTION = "i.MX Hantro VPU library"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fd4b227530cd88a82af6a5982cfb724d"
+
+PROVIDES = "virtual/imxvpu"
+
+SRC_URI = " \
+ ${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true \
+"
+SRC_URI[md5sum] = "79ca586c67ea9b007fa772df8959c852"
+SRC_URI[sha256sum] = "1f373f5d9a37754f7936f9bf4b134b65afe98459c0383b63c50c1f6ecba49e25"
+
+inherit fsl-eula-unpack use-imx-headers
+
+PARALLEL_MAKE="-j 1"
+
+PLATFORM_mx8mm = "IMX8MM"
+PLATFORM_mx8mq = "IMX8MQ"
+
+do_compile () {
+ oe_runmake CROSS_COMPILE="${HOST_PREFIX}" \
+ SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
+ PLATFORM="${PLATFORM}" all
+}
+
+do_install () {
+ oe_runmake DEST_DIR="${D}" PLATFORM="${PLATFORM}" install
+}
+
+FILES_${PN} += "/unit_tests"
+
+COMPATIBLE_MACHINE = "(mx8m)"