summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-bsp/mc-utils/mc-utils_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-freescale/recipes-bsp/mc-utils/mc-utils_git.bb')
-rw-r--r--bsp/meta-freescale/recipes-bsp/mc-utils/mc-utils_git.bb28
1 files changed, 16 insertions, 12 deletions
diff --git a/bsp/meta-freescale/recipes-bsp/mc-utils/mc-utils_git.bb b/bsp/meta-freescale/recipes-bsp/mc-utils/mc-utils_git.bb
index 430d6cd8..31645061 100644
--- a/bsp/meta-freescale/recipes-bsp/mc-utils/mc-utils_git.bb
+++ b/bsp/meta-freescale/recipes-bsp/mc-utils/mc-utils_git.bb
@@ -10,7 +10,7 @@ DEPENDS += "dtc-native"
inherit deploy
SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/mc-utils;nobranch=1"
-SRCREV = "6aca560c630dc54afdef382c506f214b28f4985e"
+SRCREV = "8672a5f5abcd3a354dcab07e03f2a8a69b2e962d"
S = "${WORKDIR}/git"
@@ -19,24 +19,28 @@ MC_CFG_ls1088a = "ls1088a"
MC_CFG_ls2088a = "ls2088a"
MC_CFG_lx2160a = "lx2160a"
-do_install () {
+MC_FLAVOUR ?= "RDB"
+
+do_compile () {
oe_runmake -C config
+}
+do_install () {
install -d ${D}/boot/mc-utils
- cp -r ${S}/config/${MC_CFG}/RDB/*.dtb ${D}/boot/mc-utils
- if [ -d ${S}/config/${MC_CFG}/RDB/custom/ ]; then
- install -d ${D}/boot/mc-utils/custom
- cp -r ${S}/config/${MC_CFG}/RDB/custom/*.dtb ${D}/boot/mc-utils/custom
- fi
+ cp -r ${S}/config/${MC_CFG}/${MC_FLAVOUR}/*.dtb ${D}/boot/mc-utils
+ if [ -d ${S}/config/${MC_CFG}/${MC_FLAVOUR}/custom/ ]; then
+ install -d ${D}/boot/mc-utils/custom
+ cp -r ${S}/config/${MC_CFG}/${MC_FLAVOUR}/custom/*.dtb ${D}/boot/mc-utils/custom
+ fi
}
do_deploy () {
install -d ${DEPLOYDIR}/mc-utils
- cp -r ${S}/config/${MC_CFG}/RDB/*.dtb ${DEPLOYDIR}/mc-utils
- if [ -d ${S}/config/${MC_CFG}/RDB/custom/ ]; then
- install -d ${DEPLOYDIR}/mc-utils/custom
- cp -r ${S}/config/${MC_CFG}/RDB/custom/*.dtb ${DEPLOYDIR}/mc-utils/custom
- fi
+ cp -r ${S}/config/${MC_CFG}/${MC_FLAVOUR}/*.dtb ${DEPLOYDIR}/mc-utils
+ if [ -d ${S}/config/${MC_CFG}/${MC_FLAVOUR}/custom/ ]; then
+ install -d ${DEPLOYDIR}/mc-utils/custom
+ cp -r ${S}/config/${MC_CFG}/${MC_FLAVOUR}/custom/*.dtb ${DEPLOYDIR}/mc-utils/custom
+ fi
}
addtask deploy after do_install