summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-devtools/cst/cst_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-freescale/recipes-devtools/cst/cst_git.bb')
-rw-r--r--bsp/meta-freescale/recipes-devtools/cst/cst_git.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/bsp/meta-freescale/recipes-devtools/cst/cst_git.bb b/bsp/meta-freescale/recipes-devtools/cst/cst_git.bb
index 05d2d4c7..fef0fbcf 100644
--- a/bsp/meta-freescale/recipes-devtools/cst/cst_git.bb
+++ b/bsp/meta-freescale/recipes-devtools/cst/cst_git.bb
@@ -4,14 +4,22 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=e959d5d617e33779d0e90ce1d9043eff"
-DEPENDS += "openssl"
+DEPENDS += "openssl cst-native"
RDEPENDS_${PN} = "bash"
+GENKEYS ?= "${STAGING_BINDIR_NATIVE}/cst/gen_keys"
+GENKEYS_class-native = "./gen_keys"
+
inherit kernel-arch
+# specify the non default keys pair for secure boot if needed
+#SECURE_PRI_KEY = "/path/srk.pri"
+#SECURE_PUB_KEY = "/path/srk.pub"
+
SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/cst;nobranch=1 \
+ file://0001-tools-Mark-struct-input_field-file_field-extern.patch \
"
-SRCREV = "f599f6126ae1a382a581dcd75e9ad2e34c79a183"
+SRCREV = "9aafbdf2441858ceca2779279b6876c6bdc2d3ed"
S = "${WORKDIR}/git"
@@ -21,6 +29,13 @@ PARALLEL_MAKE = ""
do_install () {
oe_runmake install DESTDIR=${D} BIN_DEST_DIR=${bindir}
+
+ if [ -n "${SECURE_PRI_KEY}" ]; then
+ cp -f ${SECURE_PRI_KEY} ${D}/${bindir}/cst/srk.pri
+ cp -f ${SECURE_PUB_KEY} ${D}/${bindir}/cst/srk.pub
+ elif [ ! -f ${D}/${bindir}/cst/srk.pri -o ! ${D}/${bindir}/cst/srk.pub ]; then
+ cd ${D}/${bindir}/cst && ${GENKEYS} 1024
+ fi
}
FILES_${PN}-dbg += "${bindir}/cst/.debug"