summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-devtools/cst
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-freescale/recipes-devtools/cst')
-rw-r--r--bsp/meta-freescale/recipes-devtools/cst/cst/0001-tools-Mark-struct-input_field-file_field-extern.patch43
-rw-r--r--bsp/meta-freescale/recipes-devtools/cst/cst_git.bb19
2 files changed, 60 insertions, 2 deletions
diff --git a/bsp/meta-freescale/recipes-devtools/cst/cst/0001-tools-Mark-struct-input_field-file_field-extern.patch b/bsp/meta-freescale/recipes-devtools/cst/cst/0001-tools-Mark-struct-input_field-file_field-extern.patch
new file mode 100644
index 00000000..d25675aa
--- /dev/null
+++ b/bsp/meta-freescale/recipes-devtools/cst/cst/0001-tools-Mark-struct-input_field-file_field-extern.patch
@@ -0,0 +1,43 @@
+From 81ec65e72f357fb2c395e40c5195434bbaddf7f7 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 16 May 2020 08:21:52 -0700
+Subject: [PATCH] tools: Mark struct input_field file_field extern
+
+This struct is already defined in common/parse_utils.c
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ tools/header_generation/create_hdr_common.c | 2 +-
+ tools/pbi_creation/create_pbi_common.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tools/header_generation/create_hdr_common.c b/tools/header_generation/create_hdr_common.c
+index bfa90a3..edf632c 100644
+--- a/tools/header_generation/create_hdr_common.c
++++ b/tools/header_generation/create_hdr_common.c
+@@ -39,7 +39,7 @@
+ #include <crypto_utils.h>
+
+ extern struct g_data_t gd;
+-struct input_field file_field;
++extern struct input_field file_field;
+
+ extern char line_data[];
+ static struct option long_options[] = {
+diff --git a/tools/pbi_creation/create_pbi_common.c b/tools/pbi_creation/create_pbi_common.c
+index ff2ed84..bd976da 100644
+--- a/tools/pbi_creation/create_pbi_common.c
++++ b/tools/pbi_creation/create_pbi_common.c
+@@ -57,7 +57,7 @@ static char *parse_list[] = {
+
+ extern struct g_data_t gd;
+ extern char line_data[];
+-struct input_field file_field;
++extern struct input_field file_field;
+
+ #define NUM_PARSE_LIST (sizeof(parse_list) / sizeof(char *))
+
+--
+2.26.2
+
diff --git a/bsp/meta-freescale/recipes-devtools/cst/cst_git.bb b/bsp/meta-freescale/recipes-devtools/cst/cst_git.bb
index 05d2d4c7..fef0fbcf 100644
--- a/bsp/meta-freescale/recipes-devtools/cst/cst_git.bb
+++ b/bsp/meta-freescale/recipes-devtools/cst/cst_git.bb
@@ -4,14 +4,22 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=e959d5d617e33779d0e90ce1d9043eff"
-DEPENDS += "openssl"
+DEPENDS += "openssl cst-native"
RDEPENDS_${PN} = "bash"
+GENKEYS ?= "${STAGING_BINDIR_NATIVE}/cst/gen_keys"
+GENKEYS_class-native = "./gen_keys"
+
inherit kernel-arch
+# specify the non default keys pair for secure boot if needed
+#SECURE_PRI_KEY = "/path/srk.pri"
+#SECURE_PUB_KEY = "/path/srk.pub"
+
SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/cst;nobranch=1 \
+ file://0001-tools-Mark-struct-input_field-file_field-extern.patch \
"
-SRCREV = "f599f6126ae1a382a581dcd75e9ad2e34c79a183"
+SRCREV = "9aafbdf2441858ceca2779279b6876c6bdc2d3ed"
S = "${WORKDIR}/git"
@@ -21,6 +29,13 @@ PARALLEL_MAKE = ""
do_install () {
oe_runmake install DESTDIR=${D} BIN_DEST_DIR=${bindir}
+
+ if [ -n "${SECURE_PRI_KEY}" ]; then
+ cp -f ${SECURE_PRI_KEY} ${D}/${bindir}/cst/srk.pri
+ cp -f ${SECURE_PUB_KEY} ${D}/${bindir}/cst/srk.pub
+ elif [ ! -f ${D}/${bindir}/cst/srk.pri -o ! ${D}/${bindir}/cst/srk.pub ]; then
+ cd ${D}/${bindir}/cst && ${GENKEYS} 1024
+ fi
}
FILES_${PN}-dbg += "${bindir}/cst/.debug"